No announcement yet.

Problems with Some Sounds on Black Label Decoders

  • Filter
  • Time
  • Show
Clear All
new posts

  • Problems with Some Sounds on Black Label Decoders

    Hello everyone,

    I have both a Mallard and a Silver Fox Black Label A4. They are very nice models but I am having some issues with getting the sounds to work properly. In particular, on both models I cannot get the coupler sound to operate when I press the appropriate function button. Indeed, no sound occurs when the locomotives are stationary but when they are moving the function button sounds two short horn blasts instead. As this is a problem on both models, I am wondering if there is something about the operation of this sound that I'm missing. In addtion, some of the crew conversations seem to be repeated on different function buttons - that is, I seem to get the same conversation whetiher I press F19, F20, or F21..

    In trying to resolve this problem I have attempted the following:

    I have tried to reset the decoder on the Mallard model by setting CV8 to 8 but that has not resolved the problems.

    I have also investigated whether there was something not right with the function key mapping as per the instructions on pages 11 and 12 of the A4 owner's manual,. If I understand the table on page 11 correctly, when I read CV46 (for F13) it should read a value of '14' to activate the coupling sound, however a different number came up on my system. Even when I program '14' into CV 46 this does not change the problems I'm experiencing with the replacement of the coupling sound with horn sound. Again, I may be doing something wrong here as I am having trouble understanding the instructions on page 12 of the manual. There it states as an example, "to assign Injector to Function 7, enter 12 into CV40". However, when I look at the table of values on page 12, the Injector is given a value of 5, not 12 (which is for safety valves).

    I use the Roco Z21 DCC system. I should add that I program on a programming track, not on the main. I did try reading the Silver Fox decoder on the main line but I could not get my system to recognise the decoder. On the programming track, I have had no problems changing the locomotive addresses for instance.

    As I'm in Australia, I am hoping not to have to return these locomotives to Dapol - it cost me a fortune in customs duites when they first arrived!

    Is anyone able to provide a solution or perhaps signal what I might be doing wrong? As mentioned, trying to reset the decoder has not helped.

    Cheers and much thanks for any help,


  • #2
    Hi Brian, only just come across your post, wondering if you have received any assistance with your problem? It seems a long time without a response.


    • #3
      ! you are quite right with regard to F19,20, 21 they are the same it is not your loco and yes their are errors in the manual. I will check mine this week regarding the coupler sound following a run this weekend, I hope that you have not sent them back as it is a tying error


      • #4
        I have checked my 2 black labels locos, on my NCE system and the coupler worked alright on both loco's {f13}, however CV 13 value is 4 hope this helps.


        • BryanHowieson
          BryanHowieson commented
          Editing a comment
          Hi Jimp, Many thanks for your kind reply. I have only just seen your messages as I gave up looking for a response some time ago. I'm glad to know that the problem with the repetitve crew dialogue is not just with my locos.

          Can I ask if you can please clarify what you mean about CV13? I cannot see how CV 13 is relelvant given what's in the manual. Do you mean that to correct the sound in F13, I need to change the value of CV46 to 4?

          If the table on page 12 of the manual is wrong, does anyone know if Dapal have issued a correction somewhere? This would be very helpful!

          Cheesr and many thanks,


        • BryanHowieson
          BryanHowieson commented
          Editing a comment
          Hi again, I have just reread the value for CV46 on my Mallard and it is already set at 4. I tried overwriting the value with 4 again to see if that would reset it but F13 still is silent when the loco is not moving and it makes two horn sounds when the loco is moving. I then tried overwriting CV46 with the value of 14 that is given in the table in the manual and this resulted in steam release sounds when F13 was activated. It looks like I am still going to have to live with this problem unless I can find the time to waste tring mulitple values for CV46 (which may not be successful in the end anyway!).

          Thanks for your help Jimp.



      • #5
        Hi The loco will not make any sound when you press F13, it will only work once when you move the loco backwards (I only tested it backwards).

        Sorry for F13 i did mean cv 46 = 4


        • BryanHowieson
          BryanHowieson commented
          Editing a comment
          Thanks Jimp. Yesterday morning I received an update for the Z21 iphone app. This seems to have solved the problem in that the coupling sound now works on both of my A4s! Why one function would not operate as it should but others were fine, is a considerable mystery to me! I was able to get a coupling sound when the loco initially starts going forward to.

          Thanks again. I'm glad this problem is now solved.

      • #6
        Hi all,

        A similar issue with both my A4's for function 11 which is the safety valve. It won't go on prompt, instead leaving the function as latched and as some point it may activate the once during running.

        Any thoughts?

        Kind Regards



        • #7
          creilly81 If as you say, the function is latching on, then this is a function of your DCC controller. Most systems allow function keys to be designated latching or non-latching. Your manual will tell you how to change of possible. Some systems allow this on a loco by loco basis.
          If you cannot change this then try to gain the habit of hitting the function key twice. This will "Un toggle' and the sound will run to completion.
          Last edited by Andy Dapol; 22 August 2017, 18:19. Reason: Fat finges

          Dapol Staff Member


          • creilly81
            creilly81 commented
            Editing a comment
            Hi Andy,
            Getting function 11 itself to sound is hit and miss that's what I meant. Pressing F11 on my controller may or may not operate the sound function on either Bittern or Mallard at any point.
            If I'm doing an extended running session with either or both loco's I tend to switch F11 on at the beginning and leave it on knowing that at some point during the run the safety valve function on the locomotive will sound at a random point. Is this correct?
            My understanding with both of the identical other loco's I had was, the safety valve would operate upon command (I.e when the function button F11 was pressed).
            Mine doesn't appear to

        • #8
          Hi ,,this is my first posting on this Dapol forum ,,,the question I have is ,,,,will the black label range work with no problems with my NCE powercab controller,,,I'm very interested in purchasing a refurbished mallard ,,,,,I don't want to experience problems whatever they may be to spoil the fun ,,,does anyone have the same CONTROLER and a black label A4 ,,,,is everything ok ,,,,THANKYOU Martin


          • Joel Dapol
            Joel Dapol commented
            Editing a comment
            Yes, this is the controller we use on our own test track (along with a Gaugemaster Prodigy) and it works fine.

        • #9
          Hi it is the only one I use and it works fine


          • #10
            Hi mjb, I use a number of dcc controllers, including the NCE Powercab, and can confirm it works well with this controller.


            • #11
              THANKYOU for your replies,,,,,and reassurance,,,I shall go ahead and get one ,,,,,thanks again. Mjb


              • #12
                Hi,,,,finally bought one ,,,ordered a refurbished mallard over the phone today also an extra bottle of steam oil ( authentic smell ),,looking forward o its arrival ,,,mjb


                • #13
                  She arrived this morning ,,,haven't run her yet but inspection tells me it is quality ,,it's a refurbished mallard but if I didn't already know I wouldn't have known ,,it is in mint condition ,,the box and contents also ,,,nothing missing in the box ,certificate ,( 45 / 400 ) instructions ,receipt ,,,everything ,,,,THANKYOU dapol ,,,,,,mjb


                  • #14
                    Given her a short test today ,,,run great straight out of the box ,,put a drop of oil in and it really does look the part ,,,the only function I can't get to work is the f13 coupling,but having read about it in above posts I haven't tried it yet whilst moving so not overly worried ,,on a whole I would say this black label mallard is beautiful,/ brilliant and stunning ,,,will definitely be looking to buy another ,,hopefully a refurbished golden eagle will be available,,,,anyway top marks from me Dapol ,,,,martin


                    • #15
                      I have the same problem with F11 and F13 no matter what I try it’s no better , if anyone can help much appreciated..