Announcement

Collapse
No announcement yet.

Class 68 Update - Production

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #61
    Well, it arrived today (68010 in Chiltern livery), and overall it's an excellent model - the detailing is done well, and it runs very well too.

    Comment


    • 159220
      159220 commented
      Editing a comment
      Mine has been dispatched today from Kernow. But I am now off to Heathrow at 5 am so shall have to wait to see it in 10 days time Looking at retailers photos, looks spot on! Jealous of everyone who has theirs.

  • #62
    Postie has just delivered 68 007 Valiant. A truly stunning model, practically perfect in every way. The livery and detailing are stunning and it runs like a dream. I can see 68 006 being purchased shortly

    Comment


    • #63
      Now then, having waited since the announcement for this model way back in April 2014 today the time finally arrived for me to unbox my very own 68005 Intrepid. Having being watching this forum over the last few days it's been clear to see that a few people are not satisfied with the error noted on the DRS examples. I've looked at the pictures and compared and indeed there is a livery error which is annoying I won't deny, however is this the first headline model that has appeared with a livery error? No, it most certainly isnt. I've lost count now of the number of Hornby & Bachmann locos and units I've ended up returning to the shop not because of livery errors but worse problems such as motor or light issues etc.

      I personally think the locos look spot on and its clear that a hell of a lot of effort has gone into them. I know the livery, absence of an extra socket on the buffers and the slightly chunky nameplates is annoying but these can and I'm sure will be remedied in due time. I personally love the model and my hat is raised to Dapol for putting them through. Well done all!
      Last edited by tomdonnelly87002; 17 February 2017, 16:24.

      Comment


      • #64
        From what I've seen it looks a fabulous model.

        I'm looking forward to receiving mine.

        It's disappointing to see the issue regarding the wonky nameplates and I'm hoping that the supplier is sorting and checking them first to ensure only good models go out.

        If they have a small amount of glue on they will probably come off quite easily, it's the one's where it appears that excessive glue has been appllied are the ones to worry about.

        Comment


        • #65
          Is the 68 supplied with valances/detailing for both ends? I've not yet noticed any model photos with valances at both ends.

          Some of us don't always use tension lock couplings and like full detail at both ends.

          Can anyone confirm or otherwise regarding end detail packs?

          Comment


          • newbryford
            newbryford commented
            Editing a comment
            post#13 makes no reference to the valance, unless I'm looking at another post#13...
            https://digest.dapol.co.uk/forum/mai...=4180#post4180

            I don't need a slotted valance.

            Will the valances be available as an extra?

          • JeremiahBunyan
            JeremiahBunyan commented
            Editing a comment
            Sorry, never knew about the issue of only one valance being provided. Thought you asked in general about full valances, hence pointed you to a post showing a full valance on the front.

          • Joel Dapol
            Joel Dapol commented
            Editing a comment
            A box of spares has just arrived, please give us a couple of days to sort through and catalogue them and details will be made available.

        • #66
          I have to say that the detailing on my 68002 is superb. I'm very pleased with it. I have posted this as a reply in an earlier comment but I have a question.

          I'm a bit of a technophobe when it comes to decoder mapping. I've used a TCS 1344 EU621 21 Pin 6 Function Decoder. Currently I can independently control the lights on the end with the coupling via F1 and F2 but not at the cowling end, the headlights and tail lights are just directional. What do I need to do to independently control the headlights, halo etc on the detailed end? Thanks.

          Comment


          • PeterG
            PeterG commented
            Editing a comment
            Hi robf
            I too have used TCS 1344 EU621 like yourself, this is what happens with both of my Cl 68's. I have set switches 1 & 2 to posn. 3 i.e. cab light on when trailing.
            Switch3 is in posn.1

            Cab end#1, F0f(Headlights &top) in forward direction, cab light off. Red light in reverse direction and cab light on.
            Cab end #2, F1 operates headlights &top either direction, F2 operates red light either direction, Cab light on in forward direction, off in reverse.
            I haven't done any function mapping.
            Halo lights don't work at all, even using Fns. 3&4. The decoders have all 6 functions operating on my tester!

            There is a rather crude modification done to the circuit board on both my models, using fine wire between one of the decoder socket pins, and the circuit board.
            Perhaps Dapol could explain the reasons for this?

            Hope this helps to clarify the situation for you.
            Regards
            PeterG

        • #67
          Love the model based on photos I've seen, yes some livery issues but from what I can tell just a fantastic model! Can't wait to receive my DCC fitted version in a few weeks time.

          Any idea when another production run will take place?

          Comment


          • #68
            Have just received the Chiltern Livery 68014, what a great looking model, so much so I am going to get its companion

            Comment


            • #69
              Hi All I received my 68005 and 68010 a couple of days ago and must say I am extremely pleased with them both, the Chiltern
              example will receive the AAR sockets once time allows. It is a bit of a shame that the mask for the swoosh on the DRS examples seems to have
              been incorrectly placed as it does take the shine off what is in essence an awesome model, I hope this will however be corrected on future release's.
              I like new bryford would appreciate another full obstacle deflector and set of hoses as I also don't use tension locks can any body please advise if these will
              be made available ? The under frames in my opinion are sublime and the fuel tanks being the correct size for the respective loco is to be applauded
              also I have never seen the reverse european buffer modeld as a working example before is it a first ?
              i would like to thank Dapol for what is on the whole an out standing release, and as stated hope the livery issue will be resolved on future releases
              so I can expand the fleet further .

              Comment


              • #70
                Very pleased indeed with my DRS DCC ready model.
                Thanks for the tip you gave me earlier on removing the Exhaust cover, worked a treat.

                Just fitted Sound, very straightforward job, instructions on body removal, a great help. Plenty of space for the speaker, and enclosure. Just plug and go.
                Now Looks and sounds great,

                Thanks Dapol.

                Comment


                • #71
                  Have to say Im really happy with my 68002 and Im looking forward to buy another one! It's such a detailed loco and is probably the heaviest loco I have, and it's performance is second to none.

                  Well done and thankyou, Dapol.

                  Comment


                  • #72
                    I received my DRS 68002 at the end of last week. The tooling itself looks superb, though I didn't give it a test run.

                    Unfortunately, my model's nameplates were at an angle and had been applied with excess glue.

                    If that had been the only problem, I wouldn't have minded. However, the livery error (the green 'swoosh' shifted to the left on one side) was too much and I have sent the model back to the retailer to exchange it for 68010.

                    I am surprised that such a glaring livery error was still present (as it had been pointed out previously on this very forum). To any member of Dapol staff: is it yet known how or why the error was allowed to slip through?

                    Comment


                    • Jack
                      Jack commented
                      Editing a comment
                      Exactly what I've done. My 68002 order has been changed to 010 to avoid the nameplate and livery errors. Fingers crossed for the next batch to be perfected (user-fit plates and correct positioning of green).

                  • #73
                    Received both ScotRail locos, "Daring" name plate on one side a bit squint, but I can live with that.
                    Both locos run superbly, quiet and powerful.
                    Fitted TCS 1344 EU 621 decoders as "robf" but have the same issues. Maybe should have gone for the DCC fitted ones.
                    Also can someone explain to this Aussie what is meant by "Halo lights"
                    Advice to others, I use Kadee couplings but the NEM socket is bit loose so that the coupling hangs a bit low, the trip pin had to be bent up a bit to avoid catching on the rails.

                    Excellent models, sets the bar for the other RTR makers !
                    PeterG

                    Comment


                    • PeterG
                      PeterG commented
                      Editing a comment
                      Hi JeremiahBunyan , I didn't realise that the photo was the actual model! Thanks, now to figure out how to get them working.
                      PeterG

                    • Anthony566
                      Anthony566 commented
                      Editing a comment
                      Hi Peter, what did you do to get the TCS 1344 EU 621 to operate the Halo lights ?

                    • PeterG
                      PeterG commented
                      Editing a comment
                      Hi Anthony566, I commented on robf's post 71.1 but here is the bulk of it. But Halo lights aren't working

                      I too have used TCS 1344 EU621 like yourself, this is what happens with both of my Cl 68's. I have set switches 1 & 2 to posn. 3 i.e. cab light on when trailing.
                      Switch3 is in posn.1

                      Cab end#1, F0f(Headlights & top) in forward direction, cab light off. Red light in reverse direction and cab light on.
                      Cab end #2, F1 operates headlights & top non directional, F2 operates red light non directional, Cab light on in forward direction, off in reverse.
                      I haven't done any function mapping.
                      Halo lights don't work at all, even using Fns. 3&4. The decoders have all 6 functions operating on my tester!

                      There is a rather crude modification done to the circuit board on both my models, using fine wire between one of the decoder socket pins, and the circuit board.
                      Perhaps Dapol could explain the reasons for this?

                      Hope this helps to clarify the situation for you.
                      Regards
                      PeterG

                  • #74
                    Hi guys, I have 68014 in Chiltern with DCC sound on pre order, was wondering if anyone could throw any light on when the sound batch will become available?

                    many thanks.

                    Comment


                    • pegleg90
                      pegleg90 commented
                      Editing a comment
                      When do you think the DCC fitted ones will be released?

                    • Joel Dapol
                      Joel Dapol commented
                      Editing a comment
                      Straight after the sound fitted versions, the end of next week beginning w/c 13th March

                    • Mooresby
                      Mooresby commented
                      Editing a comment
                      Hi Joel - the retailer who i've pre ordered my sound fitted DRS 68 still has't received his stock yet - can you shed any light on this please?

                  • #75
                    Received my DRS Class 68 Defiant today, and very pleased with it. Nameplates are straight, no glue marks and runs very smoothly and quietly out of the box, light engine and pulling a train. It runs through both my Peco and handbuilt 00-SF pointwork very smoothly.

                    If nobody had told me about the livery alignment error on one side, I'm pretty sure I wouldn't have noticed it, so it doesn't bother me. Some of my older locos that I run quite happily have much more noticeable inaccuracies!

                    I have ordered a Zimo 6 function decoder to put in it - just test run on DC so far.

                    The one little problem is that the Valence was completely missing at the coupling end - I searched the box thoroughly and definitely not there. I don't think it can have fallen off, because when fitted it is quite a snug fit around the coupling, which should stop it falling away.

                    So I have fitted the one from the bag supplied containing the coupling for the other end, but that leaves me without a slotted valence for the other end. I could drill and file the full valence, or Joel, will Dapol be able to supply me the missing part from your spares stock? Then you will have a very happy customer!

                    Comment


                    • DavidInYork
                      DavidInYork commented
                      Editing a comment
                      Mine (67010 in Chiltern livery) was the same as regards valences - solid one on one end, none at all on the coupling end, and a single slotted one in the accessory bag.
                  Working...
                  X